三维地质剖面模板使用指南
- 三维地质剖面
- 使用指南

简介
本工程模板提供了一套完整的三维地质剖面构建管道。用户无需从零搭建模型,也无需掌握复杂的三维建模操作,只需准备一幅包含剖面线和剖面图信息的地质图,以及对应区域的高程数据,通过"改变数据源"将自有素材替换到模板管道的对应图层中,即可零成本生成自定义的三维地质剖面图。本文档以布若错幅地质图为例,介绍模板的输入图层、输出图层与图层管道;并以毕节县幅地质图为例,演示使用自有数据生成三维地质剖面的完整流程。
| 1 打开工程模板文件 2 输入图层 3 输出图层 4 图层管道介绍 5 工程模板文件使用方法 |
|---|
打开工程模板文件
打开EnviFusion软件,如未安装,请先进行EnviFusion软件的安装。EnviFusion社区版下载地址为https://ef-tutorial-videos.oss-cn-hangzhou.aliyuncs.com/Envifusion_Community_Viewer.rar,该版本安装后即可直接打开和浏览模板文件。如需对工程模板进行修改保存,请联系北水国际获取EnviFusion专业版。社区版打开界面如下:

专业版打开界面如下,与社区版相比主要增加了计算菜单:

下载地质剖面图三维化模板文件(EnviFusion-3dCrossSection-Template-20260910.rar),并将文件解压保存在本地。
点击开始,打开工程按钮
,选择并打开模板文件夹中的3dCrossSections.efp文件。在导入工程文件对话框中,数据文件选项栏选择相对路径,并将模板文件所在文件夹设为数据文件夹;或选择逐一指定数据文件,为每个文件指定来源路径,点击确定打开工程模板文件。

模板内容如下图所示:

在图层面板中,勾选图层前方的方框设置图层的可见与不可见,方框中有可见标识的图层则在视图窗口进行展示。

可在视图窗口通过按住鼠标左键旋转视图,按住鼠标中键拖动视图的方式查看视图窗口内容。
输入图层
第一个输入图层为JPEG读取器图层,为布若错幅地质图。通过开始->导入数据
按钮导入,具体如下图所示。为减少模型运算量,地质图建议保持在8-10M以内。

第二个输入图层为Rectangle#1高程_Level_14.tif图层,为布若错幅所在区域14级高程数据。通过开始->导入数据
按钮导入,具体如下图所示。

第三个输入图层为平面1图层,根据布若错幅地质图经纬度信息,构建地质图对应的边界多边形。通过创建数据->几何体->平面工具生成。
第四个输入图层为多边形1图层,根据布若错幅地质图中A-A’剖面线位置绘制的折线。通过创建数据->几何体->多边形工具生成。
输出图层
第一个输出图层为输出图层-三维地质图左部-阈值拉伸1图层。展示了经过剖面线切割后的三维地质模型。

第二个输出图层为输出图层-二维地质图-曲面→蒙板2图层。展示了布若错幅二维地质图,其中图例等信息可为三维地质图进行辅助展示。

第三个输出图层为输出图层-剖面A下图-资源图像→地质剖面1图层。展示了布若错幅A-A‘剖面。

图层管道介绍
在管道面板中可以查看本模板的图层管道,如下图所示:

JPEG读取器图层,为布若错幅地质图。通过开始->导入数据
按钮导入,
添加位置属性1图层,使用计算->通用工具->属性->添加位置属性工具,为导入的地质图添加结构网格坐标,方便下一步根据网格坐标提取剖面图像。
结构网格→提取子网格1图层,使用通用工具->网格->结构网格->提取子网格工具,将添加位置属性1图层中的A-A’地质剖面图区域提取,用于下一步的地质界线绘制。
使用电脑自带画图软件,读取地质图像x和y方向范围、读取A-A’剖面区域x和y方向最大最小值,通过coordCalc.xlsx文件,计算结构网格→提取子网格1图层属性面板数据子面板中的子网格坐标参数(截图中数字为示意,以工程模板实际输入值为准)。



剖面图像→地质界线1图层,本图层将基于地质剖面图中岩性颜色绘制出露地层锚点,调整图层属性参数,在剖面图下图和上字之间自动绘制一条地质界线(橘红色)。使用地学评估->数据资源解析->剖面图像->地质界线工具完成此操作。



选区点位编辑1图层,使用通用工具->散点->选取点位编辑工具,将剖面图像→地质界线1图层中地质界线上的散点,移动到正确位置,进行地质界线的手动微调。

折线分割1图层,使用通用工具->空间拓扑->折线分割工具,为图像现有数列追加分量,分量表示图像透明度。使用地质界线将地质剖面图分为两部分,保留部分透明度为255,裁切部分透明度为0,最终生成地质剖面图A-A’中下图部分。


剖面A下图-属性筛选1图层,使用通用工具->属性->属性筛选工具,将新生成的,带有裁切标记(透明度)的散点属性,筛选保留为剖面A下图唯一散点属性,用于后期的剖面三维化。

Rectangle#1高程_Level_14.tif图层,为布若错幅所在区域14级高程数据。通过开始->导入数据
按钮导入。

平面1图层,读取布若错幅地质图中的经纬度范围,构建地质图对应的边界多边形。通过创建数据->几何体->平面工具生成。

剖分1图层,本图层将用于后续采样操作,定义布若错幅地质图对应的高程范围。直接对多边形进行采样的算法不经济,因此使用通用工具->网格->剖分工具,对网格进行三角剖分,再用于后续采样操作。
采样1图层,使用通用工具->属性->采样工具,将剖分1图层设为数据源图层,将Rectangle#1高程_Level_14.tif图层设为采样体图层,采样布若错幅地质图范围。

阈值裁切1图层,使用通用工具->网格->阈值裁切工具,将有效采样设为1,裁取布若错幅地质图范围内高程。
经纬度->投影坐标1图层,使用通用工具->地理地质->经纬度->投影坐标工具,经纬度转换为大地坐标。

曲面->蒙板1图层,使用通用工具->曲面->曲面->蒙板工具,为图层添加蒙板坐标。

计算器1图层,由于直接将二维地质图蒙板到高程图中会产生坐标误差,因此使用通用工具->属性->计算器工具,根据二维地质图尺寸重新计算蒙板坐标。
注:蒙板坐标计算方式如下:使用系统自带画图软件读取二维地质图jpg图像XY的最小坐标为(X0,Y0),最大坐标为(X1,Y1),间距为ΔX和ΔY;二维地质图内容xy的最小坐标为(x0,y0),最大坐标为(x1,y1),间距为Δx和Δy。计算器1图层属性面板中的计算公式为:
(ef蒙板坐标_X/X除数+X加数)*iHat+(ef蒙板坐标_Y/Y除数+Y加数)*jHat
可通过蒙板坐标.xlsx文件进行计算,在左侧红框内输入地质图像和地质图内容的XY坐标,在右侧绿色区域获得计算公式中的除数和加数。(截图中数字为示意,以工程模板实际输入值为准)


构造散点向量1图层,使用通用工具->向量->构造散点向量工具,构建新蒙板坐标向量ef构造向量。
在该图层渲染子面板的曲面蒙板属性中,导入布若错幅地质图做为曲面蒙板材质,ef构造向量作为蒙板坐标。调整风格和光照等属性,完成三维地质图顶面设置。

多边形1图层,根据布若错幅地质图中A-A’剖面线位置绘制的折线。通过创建数据->几何体->多边形工具生成

折线裁切1图层,使用通用工具->空间拓扑->折线裁切工具,基于上一步生成的折线,裁切构造散点向量1图层,保留剖面A-A’左侧部分。

网格属性->散点属性1图层,使用通用工具->属性->网格属性->散点属性工具,将Band_1数据,从网格数据转换为散点数据。
计算器3图层,使用通用工具->属性->计算器工具,为三维模型设置底部高程ef底座,本模板底部高程设为-300。

输出图层-三维地质图左部-阈值拉伸1图层,使用通用工具->空间拓扑->阈值拉伸工具,将Band_1和ef底座分别设置为上覆面和下垫面高程,生成三维地质体,缩放因子为2。
在该图层渲染子面板的曲面蒙板属性中,导入布若错幅地质图做为曲面蒙板材质,ef构造向量作为蒙板坐标,调整风格和光照等属性,完成三维地质图顶面设置。
界面1图层,使用通用工具->标注->界面工具,基于经纬度->投影坐标1图层生成下界面,根据二维地质图范围设置外扩系数后,用于二维地质图的展示。
注:外扩系数计算与本节第16步类似,可通过蒙板坐标.xlsx文件进行计算。在左侧红框内输入地质图像和地质图内容的XY坐标,在右侧绿色区域获得界面1图层X和Y坐标的外扩系数。(截图中数字为示意,以工程模板实际输入值为准)



输出图层-二维地质图-曲面->蒙板2图层,使用通用工具->曲面->曲面->蒙板工具,为图层生成蒙板,并导入布若错幅地质图做为曲面蒙板材质,生成二维地质图。

折线切片1图层,使用通用工具->空间拓扑->折线切片工具,多边形折线在获取网格属性->散点属性1图层中多边形折线所在位置的属性外,还添加了ef线长度属性,用于下一步的剖面映射。

输出图层-剖面A下图-资源图像→地质剖面1图层,使用地学评估->数据资源解析->资源图像->地质剖面工具,将剖面A下图-属性筛选1图层设为栅格数据,将折线切片1图层设为地质剖面线生成。

使用剖面A下图-属性筛选1图层中栅格图像剖面长度(x长度)与折线切片1图层中的ef线长度;栅格图像中按照透明度识别的高程线与折线切片1图层中Band_1高程数据进行映射,完成三维地质剖面构建。
注:纵向反转:沿剖面纵向反转图像材质,用于调整剖面起点为剖面线终点的情况。使用锚点:X方向锚点校正,用于调整剖面图像与平面地质图的横向匹配,进行平-剖面一体化协同校正。根据剖面与平面地质图岩性匹配结果,选择是否使用纵向反转或使用锚点进行调整。


添加位置属性2图层,使用通用工具->属性->添加位置属性工具,为地质剖面添加结构网格坐标。选中添加位置属性2图层,在视图面板中,选择交互添加网格
工具,读取图层中平面与剖面岩性边界校正点的x坐标,用于输出图层-剖面A下图-资源图像→地质剖面1图层进行锚点校准。


工程模板文件使用方法
如用户使用EnviFusion社区版打开本工程模板,可在视图面板查看布若错幅三维地质图剖面及其他各图层展示效果,在图层面板和管道面板中查看本模板的图层管道,在属性面板和颜色面板中查看和修改各图层属性设置。
虽然使用EnviFusion社区版无法对工程模板进行新增图层和保存操作,但可以通过导入自有数据,改变数据源方式,利用模板的管道,生成自定义三维地质体剖面。具体方法如下:
根据本工程模板输入图层要求,准备研究区域地质图.jpg,该地质图必须包含剖面线和剖面图信息;准备研究区域范围内高程数据,tif格式最佳。本文档使用的是毕节县幅地质图和毕节县幅对应区域15级高程数据。以下简称毕节县幅地质图.jpg和毕节高程.tif文件。
导入地质图文件。点击开始->导入数据
按钮,导入本地毕节县幅地质图.jpg文件,点击确定后生成毕节县幅地质图.jpg图层。在该图层属性面板渲染子面板中,点击显示隐藏高级属性
按钮,使按钮变为绿色(显示高级属性);在其他颜色属性中,关闭使用色板选项,在视图窗口可以看到导入的毕节县幅地质图。


在3D视图中,按住鼠标左键旋转视图,按住鼠标滚轮拖动图像,滚动鼠标放大缩小图像。3D视图时视图窗口上方如下图所示,点击该按钮会切换为2D视图。
读取剖面图xy范围。使用电脑自带的画图软件打开毕节县幅地质图.jpg,参考图层管道介绍步骤4内容,读取地质图像总体XY范围,剖面图(毕节县幅B-B’剖面图)xy方向最大最小值,带入coordCalc.xlsx文件,计算剖面图子网格坐标。

提取剖面图。右击添加位置属性1图层,点击改变数据源,在选择图层对话框中,选中毕节县幅地质图.jpg图层,点击确定,该图层将连接在毕节县幅地质图.jpg图层下。


在结构网格→提取子网格1图层中,输入上一步蒙板公式中计算所得子网格坐标,提取毕节县幅B-B’剖面图。在图层面板,仅使结构网格→提取子网格1图层可见,视图窗口如下所示,基于模板管道和导入的新地质图像,裁取到新地质剖面图。


绘制地质界线。选中结构网格→提取子网格1图层,点击俯视
按钮,将视图窗口切换为2D模式,此时在视图窗口鼠标按住鼠标左键拖动图像,鼠标滚轮控制图像缩放。
,
选中剖面图像->地质界线1图层,则在视图窗口可见出露地质锚点(黄色圆球),在该图层属性面板出露地层锚点列表中,点击右侧删除
按钮,删除列表内点,直至剩余两点。

按住Alt+Ctrl+左键,在视图窗口剖面图不同颜色岩性处点击,生成新地层锚点。全部点击完成后,在列表中删除之前未删除的两个点(列表中顶部两点),点击属性面板中的应用按钮,使剖面图像->地质界线1图层可见,查看自动生成的地质界线。如界线不合适,可通过调整属性面板中的各种参数,对界线进行调整。



手动调节地质界线。在剖面图像->地质界线1图层中,在属性面板渲染子面板中,将网格渲染方式设为散点,将点宽设为4,可查看地质界线上的散点。


点击视图窗口上方交换添加散点
按钮,选中地质界线上需要调整的散点,如散点较多,可使用矩形选择散点
工具框选地质界线上所有散点。

选中选区点位编辑1图层,并使其可见,点击该图层属性面板中的更新选区按钮,再点击应用,上一步中所有选中的散点都变为绿色的圆球。按住鼠标拖动圆球至适宜位置,手动调整地质界线。全部调整完毕后点击应用完成设置。


查看处理后的剖面图。关闭其他图层显示,仅显示折线分割1图层,看到处理后的毕节县幅B-B’剖面图。

提示:如用户使用的是EnviFusion专业版,且地质界线比较简单时,可使用计算->创建数据->几何体->多边形工具,自行在地质界线位置绘制折线,绘制完成后直接进行折线分割。
设置地质图所在区域边界。读取地质图中的经纬度范围,选中平面1图层,在该图层属性面板数据子面板中填入地质图经纬度范围,生成边界多边形。注意经纬度单位为度,分秒数据需要自行换算。

导入高程文件并根据地质图范围进行裁切。点击开始->导入数据
按钮,导入毕节高程.tif文件,并右击采样1图层,改变数据源,将采样体图层选为毕节高程.tif图层上。此时仅将阈值裁切1图层设为可见,可在视图窗口看到毕节县幅地质图对应的高程图像。


设置坐标变换参数。选中经纬度->投影坐标1图层,根据毕节县幅地质图情况进行坐标变换。可选择常见坐标系,或使用指定EPSG代码或指定Proj4代码形式设置坐标系。毕节县幅地质图投影坐标系Proj4代码为:+proj=tmerc +lon_0=105.375000 +lat_0=0 +k=1 +x_0=500000 +y_0=0 +ellps=GRS80 +units=m +no_defs。

如无需进行坐标变换,则可省略本图层,将曲面->蒙板1图层和界面1图层直接连接于阈值裁切1图层。
重新设置扩大蒙板坐标参数。选中计算器1图层,根据图层管道介绍步骤16内容,在画图软件中读取地质图图像和图内容XY坐标,使用蒙板坐标.xlsx文件,计算扩大蒙板公式中的除数和加数,设置计算器1图层属性面板中的计算公式。
毕节县幅地质图扩大蒙板公式为:(ef蒙板坐标_X/1.746055+0.214434)*iHat+(ef蒙板坐标_Y/1.651156+0.318638)*jHat

选中构造散点向量1图层,在该图层属性面板渲染子面板曲面蒙板属性下,导入毕节县幅地质图作为蒙板材质,完成毕节县幅地质图蒙板设置。仅构造散点向量1图层可见如下图所示:


绘制毕节县幅剖面线。选中多边形1图层,按住Alt+Ctrl+左键,分别点击地质图中B-B’剖面两端,在多边形1图层属性面板数据子面板坐标参数中,删除原始两个点,点击应用后剩余两点组成B-B’剖面线。

展示三维地质图左部。选中输出图层-三维地质图左部-阈值拉伸1图层,并仅该图层可见。在该图层属性面板数据子面板中,为标量数列选择表示高程数据的数列,并根据自有数据实际情况设置适宜的缩放因子。
在渲染子面板曲面蒙板中,导入毕节县幅地质图。并根据视图展示情况自行调整该图层风格、光照等属性。点击视图上方的2D/3D切换按钮,将视图转换为3D模式,转动三维地质图进行查看。

修改二维地质图界面参数,展示二维地质图。选中界面1图层,参考图层管道介绍步骤23,根据毕节县幅地质图图像和图内容XY坐标,蒙板坐标.xlsx文件,自定义该图层属性面板中的外扩系数参数。

输出图层-二维地质图-曲面->蒙板2图层,在渲染子面板曲面蒙板中,导入毕节县幅地质图;在坐标变换属性中,将Z方向平移设为1800(本参数根据最终剖面的展示高度设置)。并根据视图展示情况自行调整该图层风格、光照等属性。

三维地质剖面图设置。选中输出图层-剖面A下图-资源图像→地质剖面1图层,并使其可见。转动视图到可以看到剖面的视角,查看三维地质剖面情况,根据情况关闭该图层属性面板数据子面板中的纵向反转选项,三维地质剖面图如下图所示。


三维地质剖面图校正。参考图层管道介绍步骤27内容,对照平面地质图和剖面图岩性,在添加位置属性2图层中,读取校准点的X坐标,填入输出图层-剖面A下图-资源图像→地质剖面1图层属性面板数据子面板的X方向锚点中,进行剖面图校准。
注意:X方向锚点填写需要从X为0方向开始,每两个数为一组,第一个数为剖面校正点对应X坐标,第二个数为平面校正点所在X坐标。

EnviFusion社区版用户可调整视图角度后,点击截图按钮,选择适宜的分辨率保存图像(默认分辨率为当前视图分辨率)。


EnviFusion专业版用户点击开始->保存工程
,将本项目efp工程文件保存在本地。如需再次打开该工程,可在EnviFusion专业版中点击开始->打开工程
,选择保存在本地的efp文件,选择本工程中用到的三个文件的路径,点击确定打开文件。
注:如3个导入文件未发生位置变化,可直接使用绝对路径;如文件位置发生变化,文件都放在一个文件夹中,可使用相对路径定义文件夹位置;如文件位置发生变化且文件位置不统一,则使用逐一指定数据文件。
